[Seattle-SAGE] VSFTPD login issues

Kevin Jones KJones at tcloud.com
Thu Jan 13 17:41:04 PST 2005


Hello all,

  Now that I've got the egg cleared up from my face, I can let you know
what it was...

  Bill Pierce helped out on this one.  He tracked down all the
references to the chdir call that was dying on login.  Turns out that
the "upstream" directories weren't all completely correct in their
permissions settings.

  It turned out that I had changed the world permission settings to '0'
and this prevented the user from having access further down the tree.
Once the world permission was set to rw- again, all was well.

  It's funny how sometimes it is the basics that get you.

  Bill's perusal of the System Calls Man Page gave him some
troubleshooting steps that narrowed down the culprit of the higher level
directory permissions settings.  For those that are not aware of them,
the System Call Man Pages have more information that will help with
troubleshooting than the standard command man pages.  That is what this
noob learned today.

Thanks for the input,
Kevin


-----Original Message-----
From: W.H. Jamison, Jr. [mailto:whjamisonjr at mac.com] 
Sent: Thursday, January 13, 2005 5:33 PM
To: Kevin Jones
Subject: Re: [Seattle-SAGE] VSFTPD login issues

 It's been a long time since I looked at ftp, but do you have the
ftponly shell as an entry in /etc/shells. Just a thought.

Jamie Jamison

On Thursday, January 13, 2005, at 02:51PM, Kevin Jones
<KJones at tcloud.com> wrote:

>
><<Original Attached>>_______________________________________________
>Members mailing list
>members at lists.seattle-sage.org
>http://lists.seattle-sage.org/mailman/listinfo/members
>
>



More information about the Members mailing list